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About this page

This is an in-progress scratch-pad of notes to build release notes from as and when we release. Please do not list features that are to
be shipped already in the 5.1 release! Please do not add wish-list features that you hope will be implemented, but only what actually
is implemented already.

What does a good feature look like here:

It has a description, and a way for a busy reviewer, to find and play with the feature. Target someone who is extremely busy,
and knows little-to-nothing about the product. So if a user interface element is key to the feature, be very explicit about where
it is, e. g. Menu ▸ Format ▸ Character ▸ Position [tab] ▸ ‘90 degrees’ paths to the elements you changed. Of course, you know
your feature is important, and that everyone should care about the Extensible AutoShapes Properties dialog  – but often the
guys taking the screenshots and writing the notes do not.

It credits the main authors who did the work – just add them in brackets after the feature, where possible.

If the feature can be shown off with a sample / test file – particularly for new import-able features, it would be wonderful to
have a link to/up-load of a test file that we can use to show that feature off to best effect. That really helps us to make good
screenshots to show off the features, and allows reviewers to do their testing.

Thanks in advance for your help filling this out!

Writer

New drawing tools were added (that were previously available only in Draw), including Filled Curve/Polygon/Freeform Line, as
well as Polygon (45°). tdf#89646 (Gülşah Köse)

New button added to standard toolbar for showing/hiding track changes toolbar. tdf#90187 (Gülşah Köse)

Curve button became a split button and related with a toolbox including 5 new drawing tools. tdf#89646 tdf#90505 (Gülşah
Köse)

New toolbox on drawing toolbar
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Data Sources keyboard shortcut was changed from F4 to Ctrl+⇧ Shift+F4 to unify it with Calc. tdf#97906 (Yousuf Philips)

Additional tweaks to the menu items in the main menu bar. tdf#91781 (Yousuf Philips)

Single Toolbar Mode

The Standard (Single Mode) toolbar was created to be used as an single toolbar alternative to the default double toolbar
arrangement and it contains the most used function, insert, and formatting operations. tdf#92218 (Yousuf Philips)

Single Toolbar Mode

Selection Filter in Cross Reference Tab

Added a "filter" to Insert ▸ Fields ▸ More Fields ▸ Cross-references tab. Users can type a few characters to narrow the list.
tdf#32364 (Akshay Deep)

Cross Reference Tab: Selection Filter UI

Redesigned Bookmark dialog window

Revamped Insert ▸ Bookmark dialog window. tdf#90855 (Jakub Trzebiatowski; Yousuf Philips)

2/16

https://bugs.documentfoundation.org/show_bug.cgi?id=97906
https://bugs.documentfoundation.org/show_bug.cgi?id=91781
https://bugs.documentfoundation.org/show_bug.cgi?id=92218
https://bugs.documentfoundation.org/show_bug.cgi?id=32364
https://bugs.documentfoundation.org/show_bug.cgi?id=90855


New Bookmark Dialog Window

Default bookmark name is taken automatically using "Bookmark N" pattern.

Displaying bookmark text, which is what follows, selection or precedes the bookmark.

Calc

New drawing tools were added (that were previously available only in Draw), including Filled Curve/Polygon/Freeform Line, as
well as Polygon (45°). tdf#89646 (Gülşah Köse)

All of the toolbar conditional formatting buttons have been merged into a single conditional formatting group button. tdf#86567
(Maxim Monastirsky)

Easy ability to freeze the first column or first row of a sheet through the toolbar or menu View ▸ Freeze Cells. tdf#91013
(Gülşah Köse; Maxim Monastirsky; Yousuf Philips)

The button to open the multiline input now has the same size in all systems (was very thin in some environments). tdf#99701
(Samuel Mehrbrodt, CIB)

Pressing ⇧ Shift+Return in the multiline input will now insert a new line instead of moving to the previous cell. tdf#63994
(Samuel Mehrbrodt, CIB)

Cell References keyboard shortcut ⇧ Shift+F4 was removed in favor of F4, but is still available in OpenOffice.org Legacy
keybindings. tdf#97906 (Dennis Francis; Yousuf Philips)

Column Select keyboard shortcut Ctrl+⇧ Shift+Space was replaced with Ctrl+Space. tdf#96969 (Yousuf Philips)

Keyboard shortcut Ctrl+, to insert date and Ctrl+⇧ Shift+, to insert time is available to various European keyboard
layouts. tdf#88027 (Yousuf Philips)

The Standard (Single Mode) toolbar was created to be used as an single toolbar alternative to the default double toolbar
arrangement and it contains the most used function, insert, and formatting operations. tdf#92218 (Yousuf Philips)
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Single Toolbar Mode

Option to delete border from adjacent cells too in the borders tab of "Format Cells" dialog. tdf#34449 (Dennis Francis)

The new checkbox option to remove border from adjacent cells as well

Left - remove border of cells with option is not select, right - option is select

Multiple status-bar functions can be active at the same time. tdf#42629 (Dennis Francis, Dag Wieers)
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Status-bar functions Sum and Count are active at the same time

Currency drop-down list attached to currency toolbar icon makes it easy to choose and use desired currency format.
tdf#82641 (Mohammed Abdul Azeem; Michael Meeks)

Currency drop-down list

Freeze Rows and Columns button became a split button and added "Freeze First Row" and "Freeze first Column" options in
that button. tdf#91013 (Gülşah Köse - Maxim Monastirsky)

Freeze first column
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Curve button became a split button and related with a toolbox including new 5 drawing tools. tdf#90505 (Gülşah Köse)

New toolbox on drawing toolbar

Extensive function tooltips. tdf#95878 (Keigo Kawamura)

Tooltip describes the function and its arguments

New spreadsheet functions

RAWSUBTRACT to subtract numbers without canceling out small roundoff errors. tdf#71459 (Eike Rathke (Red Hat, Inc.))

=RAWSUBTRACT(a,b,c) is like =a-b-c, but the - minus operator cancels out small roundoff errors that are due to the
fact that not every decimal number can be exactly represented as a binary floating point number and effectively the
operation snaps to zero. RAWSUBTRACT uses the IEEE754 operation the platform/compiler provides. For example,
=0.3-0.2-0.1 results in 0, whereas =RAWSUBTRACT(0.3,0.2,0.1) results in 2.77555756156289E-17

Note: Uncheck Tools ▸ Options ▸ Calc ▸ Calculate ▸ Limit decimals for general number format to get this result.

This can be used to compare whether a result exactly matches an expected number, i.e. if
=RAWSUBTRACT(result,expected) equals 0.0

FORECAST.ETS a set of forecasting functions that use triple and double exponential smoothing and handle seasonal effects.
tdf#94635 (Winfried Donkers)

The Holt-Winters algorithms are used. Both Additional and Multiplicative methods are supported for triple exponential
smoothing.

The set consists of the functions FORECAST.ETS.ADD*, FORECAST.ETS.MULT, FORECAST.ETS.SEASONALITY*,
FORECAST.ETS.PI.ADD*, FORECAST.ETS.PI.MULT, FORECAST.ETS.STAT.ADD* and FORECAST.ETS.STAT.MULT.
The functions marked with * are interchangeable with MS Excel2016.
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Example of forecasted range with prediction intervals for 95% confidence.

CONCAT an enhanced version of CONCATENATE, allowing ranges, columns and references as arguments tdf#97831
(Winfried Donkers)

The function is compatible with MS Excel 2016 function CONCAT.

TEXTJOIN to concatenate strings with delimeters between the strings. tdf#97831 (Winfried Donkers)

TEXTJOIN allows the same string arguments as CONCAT and has a string argument that will be used as delimiter
between the strings to be joined.

Also, it is possible to opt for empty cells to be skipped.

The function is compatible with MS Excel 2016 function TEXTJOIN.

IFS a cascaded IF-function tdf#97831 (Winfried Donkers)

IFS works like if A then B else if C then D else if (etc.).

The function is compatible with MS Excel 2016 function IFS.

SWITCH a multiple choice selection function tdf#97831 (Winfried Donkers)

SWITCH compares one expression with 1 to n possible values and returns the result belonging to the first values that
equals expression.

The function is compatible with MS Excel 2016 function SWITCH.

MINIFS, MAXIFS tdf#97831 (Winfried Donkers)

These statistical functions work like SUMIFS and AVERAGEIFS, but return the minimum respectively maximum value
of the resulting range.

The functions are compatible with MS Excel 2016 functions MINIFS and MAXIFS.

Changed spreadsheet functions
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WEEKDAY handles additional type argument values. tdf#100396 (Eike Rathke (Red Hat, Inc.))

For interoperability with other spreadsheet implementations the following new argument values for the second Type
parameter are accepted and let WEEKDAY return numbers from 1 to 7:

11: Monday 1 to Sunday 7

12: Tuesday 1 to Monday 7

13: Wednesday 1 to Tuesday 7

14: Thursday 1 to Wednesday 7

15: Friday 1 to Thursday 7

16: Saturday 1 to Friday 7

17: Sunday 1 to Saturday 7

Previous versions accepted all integer values as Type argument, but any number not 1 or 2 or 3 was handled the same
as 3, returning values starting with Monday=0. Now all values not of the set 1,2,3,11,12,13,14,15,16,17 let WEEKDAY
return an error.

Support wildcards to be compatible with XLS/XLSX and with ODF 1.2

Simple wildcards as known from other spreadsheet applications can now be used in formula expressions. (Eike Rathke (Red Hat,
Inc.))

Wildcards are

* (asterisk) any sequence of characters, including empty sequence

? (question mark) any character, exactly one

~ (tilde) escapes the special meaning of the following asterisk, question mark or tilde

See also tdf#72196 and related section in ODF 1.2 table:use-wildcards and OpenFormula Host-Defined Behaviors

Wildcards are supported in all functions that already supported regular expressions, which are: all database functions DAVERAGE,
DCOUNT, DCOUNTA, DGET, DMAX, DMIN, DPRODUCT, DSTDEV, DSTDEVP, DSUM, DVAR and DVARP; the functions COUNTIF,
COUNTIFS, HLOOKUP, LOOKUP, MATCH, VLOOKUP, SUMIF, SUMIFS, AVERAGEIF, AVERAGEIFS and SEARCH.

Accordingly the setting was changed, under Menu ▸ Tools ▸ Options ▸ Calc ▸ Calculate there is now a Enable wildcards in
formulas radio button grouped with Enable regular expressions in formulas and No wildcards or regular expressions in
formulas. When reading ODF spreadsheet documents with table:use-wildcards enabled or importing Microsoft Excel spreadsheet
documents the option is set to wildcards enabled.

Using named expressions and ranges with sheet-local scope on other sheets

It is now possible to use a defined name with a scope local to a sheet in a formula on any other sheet. tdf#96915 (Eike Rathke (Red
Hat, Inc.))

For example, a named range LocalName defined with scope Sheet1 can be used in a formula on Sheet2 as
=SUM(Sheet1.LocalName), usual sheet name constraints for references apply, e.g. if the sheet name contains a blank it has to be
enclosed in single quotes, as in =SUM('Other Sheet'.LocalName)

Copying named expressions and ranges while copying sheets

While copying entire sheets, named expressions and ranges that point to the copied sheet and are used by any formula cell that is
copied along with the sheet are copied to new sheet-local scoped names. tdf#75372 (Eike Rathke (Red Hat, Inc.))

For example, a document with sheet Sheet1 and the defined names

Name Expression Scope

global $Sheet1.$A$1 Document (Global)

global_global global*100 Document (Global)
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global_local local*1000 Document (Global)

local $Sheet1.$A$2 Sheet1

local_global global*10000 Sheet1

local_local local*100000 Sheet1

and formula cells using the names global_global, global_local, local_global and local_local, copying Sheet1 to NewSheet will result
in the defined names (Manage Names dialog invoked on NewSheet)

Name Expression Scope

global $Sheet1.$A$1 Document (Global)

global $NewSheet.$A$1 NewSheet

global_global global*100 Document (Global)

global_global global*100 NewSheet

global_local Sheet1.local*1000 Document (Global)

global_local local*1000 NewSheet

local $Sheet1.$A$2 Sheet1

local $NewSheet.$A$2 NewSheet

local_global global*10000 Sheet1

local_global global*10000 NewSheet

local_local Sheet1.local*100000 Sheet1

local_local local*100000 NewSheet

thus the formulas continue to work and the names point to the copied cells as expected.

Impress & Draw

Effects list moved from dialog into the Custom Animation sidebar tab. tdf#87813 (Rishabh Kumar, GSoC 2015; Yousuf Philips)

Custom Animation list has more details in it that can be seen at a glance. tdf#87812 (Akshay Deep; Yousuf Philips)

Speed drop down menus with presets are replaced with comboboxes with editable values. tdf#98037 (Akshay Deep)

Additional tweaks to the menu items in the main menu bar. tdf#91857 (Yousuf Philips)

Quick access to slide and page properties in a new 'Slide' and 'Page' content panel in the 'Properties' sidebar tab. tdf#89466
(Rishabh Kumar, GSoC 2015; Katarina Behrens, CIB; Susobhan Ghosh; Yousuf Philips)

9/16

https://bugs.documentfoundation.org/show_bug.cgi?id=87813
https://bugs.documentfoundation.org/show_bug.cgi?id=87812
https://bugs.documentfoundation.org/show_bug.cgi?id=98037
https://bugs.documentfoundation.org/show_bug.cgi?id=91857
https://bugs.documentfoundation.org/show_bug.cgi?id=89466


Showing/Hiding draw functions with option button can be used in
Impress and Draw too. tdf#89540 (Gülşah Köse)

Base

…

Chart

Automatic Y log scale is no more forced to 1 tdf#96871 (Laurent BP)

Trend line: improve rendering of polynomial equation (Laurent BP)

before f(x) = 2x^2 - x + 1
after f(x) = 2x² − x + 1
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Wrapped trend line equation to fit in chart width (LibO 5.2)

Wrap trend line equation if it is longer than chart width tdf#94004 (Laurent BP)

Distorded chart (before LibO 5.2)

Math

…

Document signing

Added support for signature descriptions. blog entry. (Miklos Vajna, Collabora)

New signature descriptions

Added support for reading SHA-256 hashes in ODF documents. tdf#76142. blog entry (Miklos Vajna, Collabora)

Added support for OOXML signature import. blog entry. (Miklos Vajna, Collabora)

Added support for OOXML signature export. blog entry. (Miklos Vajna, Collabora)

Core

…

Shortcuts

On Windows, Alt+F12 has been assigned to Tools ▸ Options. tdf#98290 (Yousuf Philips)

On Mac OS, ⌘ Cmd+G has been assigned to Find Next, ⌘ Cmd+: to Spellcheck, and ⌘ Cmd+Ctrl+F to Fullscreen. (Yousuf
Philips)
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Kernel

…

Help Contents

Updates in help pages (Adolfo Jayme Barrientos, Stanislav Horáček, Eike Rathke, Maxim Monastirsky, Yousuf Philips, Olivier
Hallot)

Extension

…

Performance

…

Infrastructure

The official TDF builds for Windows and Linux contain a crash reporter with a server based crash analysis. more info

Programmation & Support

…

Code Rebuild

…

Filters

Better import of DOCX and RTF linked graphic into LibreOffice Writer tdf#59699 blog entry (Miklos Vajna, Collabora)

Microsoft Word for DOS files can now be imported, via libwps. (Sean Young)

EMF files now display dashed and dotted lines correctly. tdf#79679 (Chris Sherlock)

EMF files now import with correct line caps and joins. commit (Stephan van den Akker)

JPEG files now export the DPI correctly. tdf#85761 (Chris Sherlock)

Some improvements done in SVGIO import filter [Insert -> Image]. More Information (Xisco Faulí)

GUI

Print to File now available within the list of printers in Print dialog. tdf#94097 (Katarina Behrens, CIB)

Video clips, charts and OLE objects will resize proportionately by default. tdf#97919 (Samuel Mehrbrodt, CIB)

Improved resizing behavior for images, videos and OLE objects: Dragging a corner will resize proportionately while dragging
an edge will resize unproportionately. tdf#84953 (Samuel Mehrbrodt, CIB)

Simplification of Character spacing. tdf#89953 (Samuel Mehrbrodt [CIB], Oliver Specht [CIB])

"Save as Template" is now available in the Save toolbar button dropdown tdf#99926 (Samuel Mehrbrodt, CIB)

Native gtk3 menubar in LibreOffice. blog post. (Caolán McNamara, Red Hat)

Native gtk3 tooltips, popovers and context menus. blog post. (Caolán McNamara, Red Hat)

Start Center

New expert configuration option "RecentDocsThumbnail" to disable thumbnails in the Start Center (Pierre Sauter) tdf#74834

Window

In Windows can switch the Keyboard-Layout per application, it is possible for LibreOffice, now. tdf#98924 (Juergen Funk, CIB)

Configuration

12/16

https://mmohrhard.wordpress.com/2016/06/19/crash-reporting-for-libreoffice/
https://bugs.documentfoundation.org/show_bug.cgi?id=59699
http://vmiklos.hu/blog/sw-linked-graphic-import.html
https://bugs.documentfoundation.org/show_bug.cgi?id=79679
https://cgit.freedesktop.org/libreoffice/core/commit/?id=fe3ac0788666294eff66bb999f68e9cce9c3169e
https://bugs.documentfoundation.org/show_bug.cgi?id=85761
http://x1sc0.blogspot.com/
https://bugs.documentfoundation.org/show_bug.cgi?id=94097
https://bugs.documentfoundation.org/show_bug.cgi?id=97919
https://bugs.documentfoundation.org/show_bug.cgi?id=84953
https://bugs.documentfoundation.org/show_bug.cgi?id=89953
https://bugs.documentfoundation.org/show_bug.cgi?id=99926
http://caolanm.blogspot.be/2016/02/native-gtk3-menubar-in-libreoffice.html
http://caolanm.blogspot.be/2016/02/current-libreoffice-native-gtk3-elements.html
https://bugs.documentfoundation.org/show_bug.cgi?id=74834
https://bugs.documentfoundation.org/show_bug.cgi?id=98924


The Tools ▸ Customize... dialog has now a new Context Menus tab, where it's possible to customize most of context menus.
tdf#93837 (Maxim Monastirsky)

…

Basic Editor

Tabs in Basic Editor have been moved to an own row to not depend on the scrollbar height (Samuel Mehrbrodt, CIB)
tdf#96683

JVM Start Parameters

Added the possibility to edit existing JVM start parameters. (Akshay Deep) tdf#97425

Revamped Find & Replace Dialog

Added Find Previous button. tdf#98417 (Akshay Deep; Yousuf Philips)

New wide layout for the Find & Replace dialog. tdf#98539 (Akshay Deep; Yousuf Philips)

Find/Replace Dialog: Condensed

Find/Replace Dialog: Expanded

Remote Files Dialog

Added Icon View and buttons for switching between modes (Szymon Kłos; Yousuf Philips; Heiko Tietze)
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GDrive 2FA: PIN request

Remote Files Dialog with icon view

Google Drive's Two-Factor Authentication (2FA) now supported tdf#87938 (Szymon Kłos)

Template Manager

New user interface for Template Manager (see this blog entry) (Akshay Deep,
GSoC 2016; Yousuf Philips; Samuel Mehrbrodt)

Template Manager layout
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Context Menu for non-browse functions

Bottom controls for browse functions

Search and combobox filters for filtering templates

Localization

…

New languages/locales with locale data

Available as default document language and for locale specific formatting.

…

Additional languages in the language list

Available for text attribution.

Apatani [apt-IN]. tdf#97386 (Eike Rathke (Red Hat, Inc.))

Interlingue Occidental [ie]. tdf#96647 (Eike Rathke (Red Hat, Inc.))

English (Mauritius) [en-MU]. tdf#99372 (Eike Rathke (Red Hat, Inc.))

French (Mauritius) [fr-MU]. tdf#99372 (Eike Rathke (Red Hat, Inc.))

Incorporation of other languages

Our goal is to support as many languages as possible. We would like to thank the following people for voluntary translation in
LibreOffice and help in preserving their native languages:

…

Improvements to proofing tools and language support

Proofing tools for Portuguese language (pt-PT) have been largely improved tdf#97439 (Marco A. G. Pinto, Olivier Hallot, and
Raimundo Moura)

168 new entries for pt-PT autocorrection

New thesaurus for Czech language (Jan Holešovský)

generated from the GNU/FDL Czech-English dictionary

provides quite good results, however incorrect synonyms may be included

for non-commercial use, also a previous reliable thesaurus can be used (available in this Apache OpenOffice
extension)

If you speak an endangered language and want to help us to achieve our goal of providing free tools for every single person on the
Earth, please join us.

Feature removal / deprecation

General

Support for embedding NPAPI Plugins (mostly Adobe Flash) in documents has now been removed.

ActiveX support is considered deprecated and may be removed in the future. If this change negatively affects your Windows
application please email the LibreOffice development list with your use case and plan for moving off of ActiveX. We specifically
want feedback if you use ActiveX to embed LibreOffice components into your application.

Support was removed for the undocumented perftune.ini flags FastPipeCommunication (commit) and
QuickstartPreloadConfiguration (commit).

Impress

The feature to show the Navigator during the presentation has been removed. tdf#96414 (Bryan Quigley)

The pointer (pen) button and its command uno:NavigatorPen have been removed from the Navigator. (Bryan Quigley)
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API changes

C++ UNO language binding and URE libraries

Headers generated for UNO structs now contain operator== and operator!= core commit
0f8ec3036f44b02aa03795ede3052a790134a90d

UNO API changes

The PathSubstitution service now has a substitution for $(username) which is replaced with the currently logged in user.
tdf#98407 (Samuel Mehrbrodt, CIB)

It's now possible to manipulate context menus via the com.sun.star.ui.UIConfigurationManager API, by using URLs
like private:resource/popupmenu/menu_name. tdf#93837 (Maxim Monastirsky)

Users of the com.sun.star.ui.XContextMenuInterceptor API, can now get the resource URL of the currently
executing context menu, as the ActionTriggerContainer attribute of the
com.sun.star.ui.ContextMenuExecuteEvent struct implements the com.sun.star.container.XNamed interface.
(It was implementing it earlier too, but was returning empty string.) tdf#93837 (Maxim Monastirsky)

The undocumented com.sun.star.ui.dialogs.TabContainerWindow service implementation (with implementation
name com.sun.star.comp.framework.TabWindowService) was removed. commit

The module com.sun.star.plugin and the NPAPI Plugin related interfaces
com.sun.star.mozilla.XPluginInstance com.sun.star.mozilla.XPluginInstanceNotifySink
com.sun.star.mozilla.XPluginInstancePeercom.sun.star.mozilla.XPluginInstanceSyncPeer
com.sun.star.mozilla.XPluginWindowPeer were removed commit core commit
06726aa39eaeba71701742d28a1a81bd1574f883

The following UNO interfaces and services were changed:

com.sun.star.xml.sax.XFastShapeContextHandler commit

com.sun.star.office.XAnnotation commit

com.sun.star.sheet.NameToken commit

com/sun/star/chart2/XRegressionCurveCalculator commit

com.sun.star.awt.XToolkitExperimental commit

Dispatch Commands

The .uno:TaskPane command and the underlying TaskPane code have been removed. The command used to show the TaskPane
which was used in Impress before it has been superseded by the Sidebar. Legacy extensions using TaskPanes are still supported by
the Sidebar. commit (Samuel Mehrbrodt, CIB)

SDK

The regcompare command-line tool in the SDK has been superseded by unoidl-check (running the latter without any
arguments prints out usage information). (It had already been used as a replacement for regcompare inside the LO build
environment, as it supports more input formats than merely the old-style binary .rdb format, so this is a move to consolidate
on a single tool again.) commit

codemaker generated C++ headers for UNO structs now contain operator== and operator!= commit
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